Linux装置confluence

  1、准备任务

  在这里拔出图片刻画

  发明显示的版本不合毛病,这是因为系统自带的jdk招致设备文件掉效

  这时候需求移除已有的设备

  yum -y remove java

  然后履行which java

  删除对应目次下的Java文件

  然后履行 source /etc/profile

  然后从新检测Java -version

  在这里拔出图片刻画

  至此jdk装置完成。

  2.装置MySQL

  (注:confluence今朝不支撑8.0版本,8.0版本的驱动为com.mysql.cj.jdbc.Driver,因此我们装置5.7版本的MySQL)

  略

  在这里拔出图片刻画

  出现这个后果的启事是:暗码过于复杂。刚装置的mysql的暗码默许强度是最高的,假设想要设置复杂的暗码就要修改validate_password_policy的值

  validate_password_policy有以下取值:

  PolicyTests Performed0 or LOWLength1 or MEDIUMLength; numeric, lowercase/uppercase, and special characters2 or STRONGLength; numeric, lowercase/uppercase, and special characters; dictionary file

  默许是1,即MEDIUM,所以刚末尾设置的暗码必须契合长度,且必须含有数字,小写或大年夜写字母,特别字符。

  有时分,只是为了自己测试,不想暗码设置得那么复杂,比如说,我只想设置confluence的暗码为123456。

  必须修改两个全局参数:

  在这里拔出图片刻画

  在这里拔出图片刻画

  此时,我们在履行末尾的SQL便可以了

  create user ‘confluence’@’%’ identified by ‘123456’;

  在这里拔出图片刻画

  2)创立一个数据库

  在这里拔出图片刻画

  3)赐与数据库权限

  在这里拔出图片刻画

  在这里拔出图片刻画

  2、装置confluence

  1.给文件可履行权

  在这里拔出图片刻画

  在这里拔出图片刻画